Can I install Joomla HBS in Joomla 1.5.x

No. Joomla HBS Support Joomla latest version 2.5.x
So you must need to have Joomla 2.5.x before use Joomla HBS.

Can I get help for install and configure Joomla HBS in my server?

Yes. Once you purchase HBS we will offer our services for install and configure our hotel booking system in your server.

Can i use multilingual feature?

Yes. You can have unlimited multilingual feature in our hotel booking system.

How GoReserva convert currency?

GoReserva integrate Google currency converter.

Can I have unlimited hotels and rooms?

Yes using GoReserva any packages you can unlimited hotels, rooms, rates. There is no limitation.